piston scuff

Any body got any ideas what might have caused this was running great then boom it slow down and lost all compression, engine was not overheated 
and had water I checked the cylinder for heat when my son came in off track cause right after it happened , the piston had 48hrs, it is on the intake side .
I am going to check water pump why I have it apart . I am a 2 stroke guy so if it was a 2stroker I know it would have been lean the piston seem good on top
little black all over and the plug had good color. any ideas would be help full 

photo (16).JPG

If, you know for a fact bike is not too lean, and your son doesnt abuse the motor, then several things could have happened.. dirt deposits slipped into cylinder, rod bearing went and piston had too much play, or yes, cylinder head warped and piston snagged on cylinder wall. Or rings were worn out at 48 hrs, gave up, then rings snagged cylinder & KABOOM

Check the small end/wrist pin for play. My guess would be the ring got snagged

Check the small end/wrist pin for play. My guess would be the ring got snagged

Ac, where you been buddy? I hit you up on the Pm board days ago

Sorry. Been busy. Just finished putting the rmz290 together with the vortex and the 2012 magneto. Starts and runs great. Going riding. Talk later

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now