Jump to content
Sign in to follow this  

Dirtbike rear brake troubles NEED HELP

Recommended Posts

So i have a 2010 kx 250f and ive bled the rear brakes 4 different times today, and they work good at the beginning, but by the end of the ride (20 mins each aprox. ), there is no preassure at all in the rear brakes. Confused on what it could be. Please help me out!

Share this post


Link to post
Share on other sites

So i have a 2010 kx 250f and ive bled the rear brakes 4 different times today, and they work good at the beginning, but by the end of the ride (20 mins each aprox. ), there is no preassure at all in the rear brakes. Confused on what it could be. Please help me out!

if your heavy on them chances are your boiling your fluid and getting fade. What type of fluid are you running?

Share this post


Link to post
Share on other sites

if your heavy on them chances are your boiling your fluid and getting fade. What type of fluid are you running?

What do you mean fade? And I am heavy on them at times. I am using DOT 4

Share this post


Link to post
Share on other sites

You say you've bled it 4 different times, do you mean in between every ride? And are you getting air bubbles out every bleed session?

Yes, 4 different times in one day i did it. And each time it would work for a little then give out. I do see bubbles every times

Share this post


Link to post
Share on other sites

Yes, 4 different times in one day i did it. And each time it would work for a little then give out. I do see bubbles every times

What brand brake fluid?

Share this post


Link to post
Share on other sites

Sounds like you are sucking air into the system somewhere. Check all of your fittings, then check the rubber gasket inside your resovoir. When you are bleeding are you adding more fluid?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×