Jump to content
Sign in to follow this  

1978 suzuki sp370 no spark

Recommended Posts

so ive had this bike for maybe a year and a half, i traded my 86 pos honda quad for it. no title but thats not a problem in ct as i only need a bill of sale. When i first bought thew bike it only needed handle bars and a gas tank. fitted some old bars i had layin around and a  kawi 600 tank put some gas in it and it fired up. rode it around in the woods and some local roads and it seemed pretty reliable always started up smoked a little when cold but whatever. it randomly died one day so i checked the spark plug it was old, worn out and not even the correct one. so i replaced that and it fired right up first kick. had it idling warming up one day before i went out for a ride and it just died. checked plug again and it seemed alright put it back in and it farted once pulled it back out to check spark and it was weak for about 3 kicks and then no spark. the previous owner did nothing maintenance wise to this bike but it never once gave him an issue besides the slippy clutch, the battery was never even charged or even had fluid in it for that matter. i dont understand why its giving me such a problem. so far ive checked everything that has to do with electrical with a charged battery of course, i bought a manual so i could know all the specs. everything seems fine from the magneto to the wiring the coil points timing, when i tested the spark plug cap the resistance was a bit low to what the manual said but there was still connection from one side to the other. i replaced the condensor for hahas still nothing i messed with the points yet again cleaned some grounds and finally got 1 or 2 weak sparks but still nothing it should be. it probobly needs a new battery but i know it should run with the one in there, i could go at it replacing everything i can but i really dont know if i should spend money on it, every review ive read shows no one likes these bikes and theyre a pain in the arse to work on. i really like the bike as ive always wanted a bigger dual sport and i love old bikes,  i dont plan on doing any hard woods riding just mostly roads and some trail short cuts. i just need some positive advice as to what i should do, i have some money to spend on parts but not a new bike. any help to get this pig goin would be very much appreciated

Share this post


Link to post
Share on other sites

i cleaned the old points and reinstalled/reset gap finally got spark and fired up, for about 5 seconds and died. petcock leaks, carb too i think i need to adjust float level and get a new petcock, thatll be fun to find i know my tank came off a kawi but i dont know the year or model i think it came from a kz600 or something, ill just have it matched up to something close im really hoping this thing starts and runs fairly easily, i thought i was gunna blow out my knee kickin it over so many times

Share this post


Link to post
Share on other sites

Get some new points in that baby, bro. Maybe a new ngk cap will help, but you might have to go for a new coil if just the points don't make her sing. Before going after the coil, tripple check that it has a good clean ground. If no ground wire, if just grounded by the bolts, add a wire from a bolt to frame and use toothed washers for some bite into the metal.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×