Jump to content
Sign in to follow this  

Leaking radiator fluid from weep hole?

Recommended Posts

I've just recently noticed a little hole under where my radiator tubes connect to the engine case and it seems to be leaking? I have an 05 crf450r with all stock radiator and pump. Could it just be a worn out o-ring or will I have to change the pump/rod that connects to the pump?

Share this post


Link to post
Share on other sites

I've just recently noticed a little hole under where my radiator tubes connect to the engine case and it seems to be leaking? I have an 05 crf450r with all stock radiator and pump. Could it just be a worn out o-ring or will I have to change the pump/rod that connects to the pump?

replace the water seal and oil seal also guessing water in tranny oil? if seals don't do it shaft maybe worn

Share this post


Link to post
Share on other sites

Is it leaking out of the hose connection or the weep hole in the bottom of the case cover where the water pump is?

 

If its the water pump seal, its an easy fix. Just replace the seal. Its easiest to work on when off the bike, so figure the inner clutch cover gasket will need replaced also. Make sure you drive the seal all the way in too. Seems like a lot of guys dont drive that seal in deep enough and they'll seep on the shaft.

Share this post


Link to post
Share on other sites

You wont if you dont pull the cover. But sometimes guys pull the cover to work on it etc.

 

Getting that seal out of there without pulling the cover can be a challenge since there's no good safe way to grab the seal. On the later engines (09-14), it cant really be done efficiently.

 

Its just food for thought. Look at how things go together. How do you dig the seal out with the pump shaft sticking through it?

 

The brake lever has to come off to get the clutch cover off too....all for a 4 dollar seal. :facepalm: 

 

May as well do both #8 and #9...One goes in from the outside, the other from the inside.

 

0900B.png

 

 

0600C.png

Share this post


Link to post
Share on other sites

I've ordered number 9 because I took it apart and it was scratched looking and I could see where it was leaking through I guess. Number 8 looked ok and the shaft seemed ok as it had no burs or anything that would catch the seals and rip. I think it is just a faulty seal :/ haha.

Edited by honda_rider_23

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×