Jump to content
Sign in to follow this  

ESR325 question

Recommended Posts

This is for those that have them...

I just got my kit in the mail Friday and over to my engine builder on Monday from what he is saying the sleeve isn't flush with the cylinder and it sticks up 5mm. The head touches the sleeve first when trying to install it. Has anyone else have this issue or is it suppose to be like that (which doesn't make sense). I'm hoping I can get an answer from them but from the pervious thread it doesn't sound like I will.

ImageUploadedByThumper Talk1398214855.667305.jpgImageUploadedByThumper Talk1398214873.078412.jpg

Share this post


Link to post
Share on other sites

I can't think of any reason why it wouldn't be flush.Call Eddie Sanders,or email him.

Share this post


Link to post
Share on other sites

I can't think of any reason why it wouldn't be flush.Call Eddie Sanders,or email him.

Yeah I've tried for two days and sent an email yesterday and today.

Share this post


Link to post
Share on other sites

I can't think of any reason why it wouldn't be flush.Call Eddie Sanders,or email him.

Yeah I've tried for two days and sent an email yesterday and today.

Share this post


Link to post
Share on other sites

I'm sure he will fix it up. Been plenty forthcoming with support once you get him on the phone.

Share this post


Link to post
Share on other sites

I'm sure he will fix it up. Been plenty forthcoming with support once you get him on the phone.

Share this post


Link to post
Share on other sites

i just checked mine, has been sitting in the living room for a couple weeks while i work on the rest of the bike and it has the exact same gap. doesn't really seem like the sleeve is sticking up though. just just seems like the inner diameter of the head sticks down a little more than the mounting surface, seems like the o ring might be thick enough but i've never had a head that used an o ring before so i'm not really sure if thats normal

Share this post


Link to post
Share on other sites

i just checked mine, has been sitting in the living room for a couple weeks while i work on the rest of the bike and it has the exact same gap. doesn't really seem like the sleeve is sticking up though. just just seems like the inner diameter of the head sticks down a little more than the mounting surface, seems like the o ring might be thick enough but i've never had a head that used an o ring before so i'm not really sure if thats normal

You running the pump gas head or Race fuel head?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×