Jump to content
Sign in to follow this  

05 yz250 problems

Recommended Posts

I just got an 05 yz250 and it idles fine in neutral but as soon as I put in gear it stalls unless I give it gas.. It lurches forward but it has a all new

Clutch basket

Share this post


Link to post
Share on other sites

Check your clutch plates they might be stuck together from sitting. When it sits the oil squeezes out of the plates and it acts like an adhesive to the plates.

Share this post


Link to post
Share on other sites

I just picked up the exact same bike about 6 weeks ago and had the exact same problem. Changed the plates and springs (and clutch cable for good measure, as the one it came with was a bit tattered), now no issues at all. My problem was exactly what Connor_ferk1 has suggested, plates sticking together from being in the garage too long. That's one of the problems with picking up a used bike, you never really know how frequently it's been ridden/maintained.  ;)

  • Like 2

Share this post


Link to post
Share on other sites

Sometimes a hard jolt will unstick the plates, but chances are they're not in the best shape after having sat "stuck" together. It may be worth it to swap out the plates/springs (they usually come altogether in a kit) just for peace of mind. 

Share this post


Link to post
Share on other sites

Okay whenever I'm done getting everything else for this bike ill take a look at them and replace them if need be it can I just take them out an soak em in acetone I heard that works

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×