Jump to content
Sign in to follow this  

tm 125 clutch problems

Recommended Posts

i have a 99 tm 125 and im having a problem with the clutch there will be no clutch there so i would bleed the sysyem and the clutch would come back and then when i go to drive the bike the clutch lever goes soft again and theres no clutch again so i kept bleeding it and trying to drive it but the same problem kept happening its like the hydraulic fluid is just dissapearing somewhere any ideas in what this could be please??

Share this post


Link to post
Share on other sites

i pulled the slave cylinder off and hydraulic fluid came out is that supposed to happen

Share this post


Link to post
Share on other sites

If your slave is like one on a ktm, hold your hand over the piston so it doesn't fall out on you. Then pump your clutch till it gets hard. If there's fluid running out around the piston then your O ring is leaking. If that's the case, then Carefully remove the piston and clean around the O ring and cylender. If it still leaks after cleaning then you'll need to replace the O ring.

Share this post


Link to post
Share on other sites

O rings are a common problem on the tm slave cylinders, when you are bleeding it are you back bleeding it using a syringe, its really the only way to bleed the clutch on them

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×