Jump to content
Sign in to follow this  

rm250 05 powervalve not working

Recommended Posts

having trying to chase a lack of top end power and reluctantce to rev I think I may have diagnosed it to the powervalves not opening. I removed the cover and revved it pretty hard and it refuses to actuate the powervalves although if I lift the sprung piece, it moves freely. is this the governor that's at fault? and roughly what do the parts cost and what is involved in replacing? thanks as ever

Share this post


Link to post
Share on other sites

I ll do. is the governor different from the actuator? I was thinking it was a groove or something in that rod/actuator but as you say it moves smoothly by hand. if it was this would it feel ''notchy'' what years are the same in terms of powervalve governor parts? is it possible  to replace just by removing clutch cover?

Share this post


Link to post
Share on other sites

could u tell me what I need to be looking for? I have the cluctch cover off, and the governor in hand. the rod pushes up free when I do it by hand. does the bit bolted to the inner crank case need to be removed to inspect? is there anything obvious I need to look for in terms of wear?

Share this post


Link to post
Share on other sites

well im stumped. the powervalve rod is clipped into the plastic clips, moves up and own freely. I have looked for pics of the governor and associated powervalve bits to no avail. also tried to find a pdf manual. i cant see if the governor ect has any wear as i don't know what a new one should look like? what should i be looking for in terms of wear. the bike is as flat as a whitches tit and revving with the powervalve side cover off shows no sign of it opening so its definitely pv related. well ive looked for a replacement governor and the one for 03/04/05 is completely different to the one I removed from my bike. so either the last owner has fitted a motor from an earlier bike, has bullshitted me with later bodywork ect or has fitted a governor from an earlier model. this could be why it wont operate properly. is it possible to phsyiclly fit the wrong governor ie will up?

Edited by mgtkr1

Share this post


Link to post
Share on other sites

can anyone help? im about to order the relevant parts ie governor and actuator for the powervalve. im unsure if the correct year engine is in my 05 frame OR if parts from other rm years are interchangeable. the governor in my 05 looks different to the govenors I seen on parts diagrams for my model

Share this post


Link to post
Share on other sites

yeathe trouble is now I want to order the parts but im not 100% on the year. I was sold it as an 05 but the uk importer doesn't recognise the barely visible frame vin (powder coated) can any help? the number on the cases is j119-100725 and the other is ether js1rh***06500441. I even tried Suzuki.com in the states but there closed

Share this post


Link to post
Share on other sites

There is supposed to be 17 numbers in the VIN, but you only gave 16. Find that other number on the plate mounted on the frame and we can tell you the year.

Share this post


Link to post
Share on other sites

yea thanks ive since found it to be an 01 model. the swingarm from 03 onwrd tapers but the actuators are the same part number from 01 onwards so that's something

Share this post


Link to post
Share on other sites

that's on the clutch side above the cover? in that case its j119 100725

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×