Jump to content
Sign in to follow this  

Drz rough at low speed/ rpm

Recommended Posts

Hello,

 

I am Piet, and i am new to the forum.
i got a 2007 drz sm that i bought with 966km from the first owner.

K&N Filter,  3 x 4 airbox mod and titaium akrapovic open exhaust. ( already done by previous owner sinds new)

I did about 1300km with it now, and im realy happy with it.
( i already removed pair system and carb solonoid stuff)

 

Bike picks up realy good, and pulls strong.   also pulls wheelies in second gear easy.
I ride the bike pretty hard, but it seems to handle it just fine.

 

The problem:

I mostly ride on country roads, but in towns i have to drive slow, 30 or 50kmp.
but at slow speeds its realy hard to drive at a steady speed, i almost can't get the rpm's at a steady speed.
But when i brake a little bit it's fine!!   so it seems to need more resistance to drive smooth.

 

I't geting kinda ennoying when i not want to drive like a hooligan true town. haha

 

 

I'm living in Holland and have dyslexia, so sorry for the bad english.

Greatings Piet

 




 

Share this post


Link to post
Share on other sites

Did the previous owner rejet the carb for the pipe and airbox/airfilter mods?  These bikes come lean from the factory and they surge at steady low rpms because of that. The pipe and extra air from the filter and cut airbox will make the condition even worse. Does it backfire when you left off the throttle?

Share this post


Link to post
Share on other sites

Did the previous owner rejet the carb for the pipe and airbox/airfilter mods?  These bikes come lean from the factory and they surge at steady low rpms because of that. The pipe and extra air from the filter and cut airbox will make the condition even worse. Does it backfire when you left off the throttle?

 

Thanks for the reply.

 

Yes i does backfire!!  alot!    thats why i removed the pair system.

so that would mean that is lean?    

I worked a lot on dirtbike's but never alot on carbs, so i have no experience with that.

But can i adjust the fuel mixture screw? or chance the clip on the needle?    

other than the low rpm's the bike run's strong!

 

Gr Piet.

 

Share this post


Link to post
Share on other sites

Basically your carb is letting in too much air and not enough fuel, you need to change the jets in the carb to allow more fuel in. As a bonus you will improve the throttle response as well.

 

Start with a JD Jetting kit https://www.thumpertalk.com/shop/JD-Jetting-Jet-Kit-DR-Z400S-SM-p2006766373.html

It has all the jets you need and instructions, be sure to take your time, read the instructions and ask questions if needed.

 

Jetting a carb can seem like a major undertaking, but its really not that hard, probably the hardest part will be getting the air boots back on the carb when done  :)

And make sure the throttle opens and closes smoothly before riding it.

 

Also, measure the hole cut in the top of the airbox, if its bigger than 3x3, use some duct tape to reduce the size of the opening

 

Good luck.

Edited by plankk

Share this post


Link to post
Share on other sites

Oke thanks,

 

But the exhaust, airbox mod and k&N filter are done by the dealer.
The mods are on the bike from new.
So im pritty sure the changed the carb jettings

 

Can i try change the needle before i buy a jet kit??

And becouse it's running so good, should i even buy a complete jet kit? ore just one main needle? or whatever i should change.

But i will make the needle change first.   ore is that a stupid idea?
 

Share this post


Link to post
Share on other sites

You can try playing with the needles in the carb, but I doubt they'll get it as close as the JD kit would.

 

I doubt the dealer rejetted the carb unless you specifically asked them to, its not a 5min job to rejet the carb. Check your receipts or ask them if they did the rejet.

Share this post


Link to post
Share on other sites

Hello,

 

I tried to lower the needle clip, but i couldn't lower it.
it's was in the 3 clip from below, and i wanted to put it in the 2.
But if i do that the needle lock thing doesn't click in there any more.
its becouse the needle and plastic lock thing toch each before it clicks in to place.

 

There already a plastic ring and thick metal ring under the needle and a thin ring on top of the clip.  is that stock?

Becous of those fill up rings it unposible to put the clip any lower. 
But ofcoure the rings already make it lower than it actualy is.
 

is this stock or already a jett kit?   i have no idea

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×