Jump to content
Sign in to follow this  

losing coolant

Recommended Posts

Ill start from the start of this issue. I raced my13 250xc in the mud and was having overheating issues. Never was a problem before but mud got caked in the radiators and you know the rest. Since then I put a 2.0 cap on and switched from standard automotive coolant to engine ice. The problem im having is, I fill the radiators up past the fins and it just pisses out. The bike itself is not even fully warmed up(you can still touch the radiators). I have not rode the bike for an extended amount of time so I dont know if it will keep pissing coolant out the whole time. Could it be possible that the new cap is bad? Im gonna switch it back to the stock 1.8 cap to see after work. Any thoughts or passed expierences would be appreciated. Im want to race tomorrow but im not going to risk it if I cant resolve this.

Share this post


Link to post
Share on other sites

If it's leaking out the overflow before it's even warm it's a good bet you need a new head gasket. If the head gasket is bad it will draw air in and pressurize your cooling system.

  • Like 1

Share this post


Link to post
Share on other sites

The problem is just at the cap?

no sorry, its out the overflow. it keeps leaking to a point that is lower thanit should be

Edited by motomanp58

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×