Jump to content
Sign in to follow this  

07 CRF250 not starting HELP!

Recommended Posts

Hey guys, im having issues with starting my bike its just had a new top end rebuild (with a vertex high compression piston kit) and valve re-shim now my bike wont start the guy who done the work for me was convinced it was all working well after he did the work for me, when i picked the bike up i bump started it and it running ok but the kick start doesn't fire the bike up, its backfired a few times during kicking it over. the mechanic told me i would need a new spark plug (as one he used was from an old bike that he was breaking) so i purchased a new plug.

 

im not entirely convinced that he has done everything i asked him to do (valve re-shim, top end, re-jetted) im not sure which one of these is causing the problem but it was working fine before

 

also since i installed a high compression piston i gathered that the kickstart would be much harder (but as ive read on forums not always the means) but not sure how it works with HC Pistons, but i don't really want the same guy to look at the bike as if he didn't do what i paid him to do he doesn't really know what hes doing, is there anything anyone can suggest i can do?

 

thanks in advance

Edited by supergimp2000

Share this post


Link to post
Share on other sites

Sounds like timing isn't set right or you valve clearances are tight. Fairly simple fixes if it is.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×