Jump to content
Sign in to follow this  

Rust spots on used camshaft

Recommended Posts

I bought a used camshaft from a 450r and it arrived today. I found it has small rust spots on the back side of the lobes and along the shaft. Before I start asking the seller for a refund, is there something I can do to remove/clean the rust off or is it a job for an engine shop?

 IMG_06371.JPG

Edited by 2004 CRF250R

Share this post


Link to post
Share on other sites

 I'd send it back...that looks like some pitting is actually starting.

 

 By the time a machine shop ground those out (and it's the ones on the cam lobes that are the worry), you'd be changing the profile of the lob quite a bit.

 

 I don't have a lot of machining experience though, so someone else may offer a more informed opinion, but if it were me, I'd return it.  Lots of used X parts floating around.

 

Jim.

Share this post


Link to post
Share on other sites

IMHO I would never put anything that looked like that in any of my bikes!

Hope you didn't pay too much for it and can get your $ back as brand new cams don't cost that much.

Share this post


Link to post
Share on other sites

yea I was expecting some light surface rust, but that looks really bad. I'd send it back without a doubt. It looks like that thing has been sitting around outside for a year.

Share this post


Link to post
Share on other sites

It actually looks alot worse than it is. I took it to a reputable engine builder and he said its perfectly fine and cleaned it off with some fine emery paper. Apparently it was only surface rust and it was limited to the back of the lobes which doesn't actually come into contact with anything. 

 

Does anyone know if the R and X cam share the same base circle or will I have to reshim when I put in the R cam?

Share this post


Link to post
Share on other sites

It actually looks alot worse than it is. I took it to a reputable engine builder and he said its perfectly fine and cleaned it off with some fine emery paper. Apparently it was only surface rust and it was limited to the back of the lobes which doesn't actually come into contact with anything. 

 

Does anyone know if the R and X cam share the same base circle or will I have to reshim when I put in the R cam?

 

Technically they are the same, but you should still check.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×