Jump to content
Sign in to follow this  

My cr125 has no power after rebuild

Recommended Posts

I just got done almost fully rebuilding a 1991 cr125 and when I went to go ride it, it just had no power at all. I cranked the throttle and it would hardly accelerate and kind of bogged. And it would never get into the power band. What is wrong? Is it the jetting? If so what jets should I change and should I go bigger or smaller? Or is it an engine problem like the timing or power valves? Any help would be appreciated.

Share this post


Link to post
Share on other sites

I'm not the best mechanic here but maybe you have a leaky gasket our you installed it wrong?

Share this post


Link to post
Share on other sites

Is the Piston in the right direction?

I believe so. I have the ring gap in the rear.

I'm not the best mechanic here but maybe you have a leaky gasket our you installed it wrong?

Maybe, but I just put all new gaskets in it

Share this post


Link to post
Share on other sites

I'm not familiar with the 125, on the 250 the ring gap is on the exhaust side, so I bet you have it right.. did you ride it before the rebuild, or you got the bike with no top end? I see 3 key things to check, make sure your main jet is the right size and not clogged, check your reeds, if they're too open then flip them around, and make sure your power valve is working right, if your powervalve isn't working then you'll never get into the power band

On a side note I'm I'm dealing with the same problem and I think its because I got a piston from the year before and it doesn't have the arch on the front of the piston like my year does

In my experience your bike should still run pretty good with low compression, unless you have no compression at all, just because they rev so fast at high rpm the compression can't leak out fast enough if that makes sense, just makes it super hard to start, my ex has an old yz80, had like 30 pounds on a compression test, should be like 150, so way bad, was gonna rebuild it for her then she broke up with me, her loss lol, its nearly impossible to start, but when it gets goin it will still power wheelie in the powerband and makes decent power

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×