Jump to content
Sign in to follow this  

Mikuni tm33 pumper carb

Recommended Posts

Bought a 91 dr350M, dirt model. Came with the pumper carb. Bike runs MINT!!!! But the rod the pressed the plunger to pump, is missing! I didn't notice when I bought it, and never had a pumper carb. So I bought the accelerator rod, and it seems it's too big? Slips right under the lever as it won't compress. The spring and plunger are fine and aren't stuck or anything. What do you guys make of this? What should I do. I'd like to have the carb do what's it's intended to do, but right now it runs mint and I don't have a problem at all with throttle response.... I'm just the guy that's always looking to make things better, sometimes I can't leave well enough alone. Help?

Don't let Monday ruin your Sunday!

Share this post


Link to post
Share on other sites

When I put the rod in, while the carb was apart, I tested the pump with some carb cleaner in the bowl. It pumps a nice stream. I'd at least like to give it a shot. If it works as good as I've heard, my bike is gonna be even more fun. I had a kdx200 a few years ago and got hurt bad in an accident. So I wanted a 4 stroke that I could take on the road (eventually) and I'm so impressed with this bike I can't stay off it!!!!! These bikes are awesome!!! MONDO ENDURO!!!

Don't let Monday ruin your Sunday!

Share this post


Link to post
Share on other sites

Man if I had a dr350 with a carb that wasn't giving you fits I would praise the lord and leave it alone. But hey I can't resist tinkering either so I understand. Report back. I agree they are cool old bikes.

Share this post


Link to post
Share on other sites

The carb is so dialed in right now I find it hard to believe that the ppr feature could and or will make it that much better.... I can twist the throttle pretty quick and the front wheel jumps off the ground.... But it's not using the pumper feature! Kinda defeats the purpose lol.... I don't know what to do

Don't let Monday ruin your Sunday!

Share this post


Link to post
Share on other sites

The only time it even remotely stumbles is if I just NAIL it... It obviously isn't getting the gas to compensate for the air when doing that.... Just don't understand why the rod won't compress the plunger? Could it be that I got a rod meant for the 34 pper? Ordered from Babbits Suzuki....

Don't let Monday ruin your Sunday!

Share this post


Link to post
Share on other sites

And when I say NAIL it, I mean from a rolling start. When I'm cruising in like 3 or 4 or 5th, I can nail it no problems

Don't let Monday ruin your Sunday!

Share this post


Link to post
Share on other sites

Ok I'll check it out again... Thanks for the vid! Seems like my rod won't budge and the lever simply slides over it? Maybe I'll post a vid

Don't let Monday ruin your Sunday!

Share this post


Link to post
Share on other sites

The spring was wrong. Was not working because the spring was totally wrong.. Oh my god! It's sooo much better and it was real real good before... Very happy fella right now!!!

Don't let Monday ruin your Sunday!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×