Jump to content
Sign in to follow this  

2014 KX100 bogging

Recommended Posts

Hi everyone, my girlfriend bought a 2014 kx100 last week and we are having issues with the carb i think. First of, we bought it full of gas, look like it as been mixed with chain saw oil, the bike is smoking like hell and oil is coming of the muffler. So after the first ride, we removed what left in the tank and mixed fresh gas and klotz super techniplate, and replaced the plug, but some gas left in the tank since the new gas still looks blue. The problem we are having is when its hot, the engine cant run at idle for more than 10 seconds, and when we squeeze the trottle wide open at idle, it bog and if i still squeeze it, it dies. Not sure what i have to do to fix it, is it the pilot jet too lean, when cold and with the choke on it, it seems to be running better. At mid rpm the engine is running good, it only happen between idle and low rpm,if i'm not wrong, it is the pilot jet being too lean, but im not sure how to confirm. What would you do? 

Edited by mathieu9836

Share this post


Link to post
Share on other sites

Dude, you really bought the wrong bike, unless you know how to set up and  ride a track two-stroke.

They have no power until 5000 rpm, and they need to be jetted for how  you ride it.

 

NEVER let a track bike sit and idle for more than a minute!

 

You need to read your owners manual on how to properly mix oil, and operate the bike.

 

Do not use Chain saw oil either!!!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×