Jump to content
Sign in to follow this  

1995 kx250

Recommended Posts

Hi everyone. I bought this kx250 in January for $700. It's in pretty good condition. I am having a problem with it though and I hope someone has an idea. I went riding in a sand pit. Then I got home power washed my bike started it and put it away. I went to go start it a few times and it seemed like it didn't have spark. Then I came today and it started first kick. I let it idle for a minute then shut it off to go help my dad. I came back to go start the bike and now it's not starting. I didn't see any spark at all so I am at a loss. Has this happened to anyone? I think I should get a new spark plug and start there. Thanks

Share this post


Link to post
Share on other sites

ImageUploadedByThumper Talk1399750653.578695.jpgImageUploadedByThumper Talk1399750668.478099.jpgImageUploadedByThumper Talk1399750707.949139.jpg

So here is where I am at. Spark plug is out and going to be replaced. Is that a FWW on the flywheel? And the ignition coil has a tear in it. Would that affect anything? Compression is at 155psi cold. It's also getting fuel from the carb so I'm at a loss. I also checked the grounds too.

Share this post


Link to post
Share on other sites

Ok so it is getting spark. It doesn't seem like a full spark but I could be wrong. Maby I'll pull the carb apart and take a look

Share this post


Link to post
Share on other sites

Could have fouled the plug from starting and shutting off the bike. I would try a new plug.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×