Jump to content
Sign in to follow this  

Suzuki SP250

Recommended Posts

Hi. I bought a 1981(2) SP250 Dual Sport and I was wondering if anyone here has any information on them. It was in Storage for 20 years and is perfect minus decals and a slight tick coming from the exhaust valves. I have adjusted the valves to spec~ and it reduced the tick, but did not eliminate it.

 

I also have to replace the air filter as the foam seal ring is basically powder. Right now its topping out at about 42mph in 4th gear where the power drops off and does not rev into 5th without a long enough road. Any idea on top speed when tuned up properly? I was thinking 65-80ish with favorable wind and flat ground.

 

Does anyone know if there is anything else in the heads around the exhaust valve that can rattle/tick?

 

Thanks for any help.

Share this post


Link to post
Share on other sites

Change oil.

Air filter,

Clean carb jets.

I had 2 sp's a 125 & 250 and 2 dr 250's before.

Very similar to the Dr.

60-70 mph if geared right.

Don't do big jumps.

Single back bone non parameter frame. More street worthy. But fun casual trail bike. Engines will run forever.

As far as the tick, it may clear up with some running. Its been quite a while, but I believe that engine makes some noise a bit anyhow. I'm sure someone else on here has had one too for verification.

Share this post


Link to post
Share on other sites

Yeah your looking at. 65 tops. It's n the gearing. The gn went a little faster cause smaller back sprocket. I didn't know they made them n 81. I thought 82 was the first. On thing is I thing those bikes came out taking regular gas for the lead. So your valves may need to be changed

Share this post


Link to post
Share on other sites

It is an 82, I couldn't remember when writing this lol. I am about to change the oil, filter looked brand new but I did take it off and wash/dry and oiled it(plus jerry rigged the foam seal with some nice home depot door foam XD)

 

I test road it after doing the filter seal and cleaning it and it seems like it pulls a bit harder up to about 45 and then starts to drop off. maybe the fresh oil spinning in there soon will give me those extra 10-15mph.

 

Also does anyone know the compression psi for the cylinder, I read that it was 8.9:1 compression but cannot find any specifics on psi.

 

for $600 this thing is a perfect money double bike, then maybe I can finish my RZ350

 

Thanks again.

  • Like 1

Share this post


Link to post
Share on other sites

I think I figured it out, main jet clogged in carb slightly, no power at top end xD. cleaning carb and seeing how it runs... I miss my RD400 its carbs were like the easiest things in the world to clean and fix. Long live 2T race bikes.

  • Like 1

Share this post


Link to post
Share on other sites

Ok I do not have time to take off the carb this evening but I did a comp test and it came up 165~ psi. Is that a bit high? I also took of the exhaust muffler and it let it rev up a bit higher but it is still not revving more than about 3k rpms. Gear speeds go 1st:20mph 2nd:30 3rd:35 4th:45ish 5th: N/A(it doesn't get there.)

 

This is leading me to believe fuel starvation. I hope its just a clogged jet. I will update in a few days when I have more time to take the carb off.

 

All in all though I am quite happy with the 4t so far. The power is less crazy than my 2t road bikes. I can go on ham fisted rides on this lol. Try that on my RD400 and the only place you would get to is the obituary :p (having your bike decide to stand up in 3rd or 4th at 50+ isn't fun when you aren't paying attention)

 

Thanks for all the information.

Share this post


Link to post
Share on other sites

Ok I do not have time to take off the carb this evening but I did a comp test and it came up 165~ psi. Is that a bit high? I also took of the exhaust muffler and it let it rev up a bit higher but it is still not revving more than about 3k rpms. Gear speeds go 1st:20mph 2nd:30 3rd:35 4th:45ish 5th: N/A(it doesn't get there.)

This is leading me to believe fuel starvation. I hope its just a clogged jet. I will update in a few days when I have more time to take the carb off.

All in all though I am quite happy with the 4t so far. The power is less crazy than my 2t road bikes. I can go on ham fisted rides on this lol. Try that on my RD400 and the only place you would get to is the obituary :p (having your bike decide to stand up in 3rd or 4th at 50+ isn't fun when you aren't paying attention)

Thanks for all the information.

That thing should tach out fine.

I bet its jetting issue.

Also check decompression release.

Make sure its not coming open on its own.

Share this post


Link to post
Share on other sites

I have an 87 SP200 I bought new when I was in the Navy, still have it, it will do about 80mph when I am tucked in, down hill, back wind, praying

 

it does get like 75 mpg

 

follow this link for help

http://kientech.com/

 

he can help you most likely with whatever you need

 

sounds like the carb is plugged up, you may not even be able to get OEM cleaner anymore, stuff for my 87 SP200H is out of stock

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×