Jump to content
Sign in to follow this  

04 crf250r hard to cold start

Recommended Posts

Hi guys! I am having difficulties starting my bike cold. I've kicked it 50+ times before with no luck. It runs fine when its warm and starts first kick and idles well. The bike had a new top end as of last year and I have put 80-100hrs on it since then. There are SS valves in it (put in with top end)and I don't think valves are the problem. Could my problem be a low compression problem from worn rings or something else? I know valves could be the problem but is there anything else that would cause these cold start probs? Thanks

Share this post


Link to post
Share on other sites

Jetting / carb issue, is the choke working?

Edited by techgreg

Share this post


Link to post
Share on other sites

Check the valve clearances, first, to see if they're within specification. After that is the time to hypothesize and research any other possible causes...

Share this post


Link to post
Share on other sites

Hi guys! I am having difficulties starting my bike cold. I've kicked it 50+ times before with no luck. It runs fine when its warm and starts first kick and idles well. The bike had a new top end as of last year and I have put 80-100hrs on it since then. There are SS valves in it (put in with top end)and I don't think valves are the problem. Could my problem be a low compression problem from worn rings or something else? I know valves could be the problem but is there anything else that would cause these cold start probs? Thanks

I was having a similar issue, and replaced my piston & rings.  Seemed to eliminate the problem.  The culprit seemed to be compression for me, but may be something else.

Share this post


Link to post
Share on other sites

I was having a similar issue, and replaced my piston & rings. Seemed to eliminate the problem. The culprit seemed to be compression for me, but may be something else.

I thought that could be it, the piston and rings have like 90hrs and I noticed a slight decrease in power when running.

Share this post


Link to post
Share on other sites

Jetting / carb issue, is the choke working?

yes the choke is working. This starting problem occurred in the last week. Does the carb just randomly get dirty or start to not work well after awhile?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×