Jump to content
Sign in to follow this  

How to get trip meter unstuck?

Recommended Posts

I need some help to unstick my Trip Meters. The meter can toggle between the Trip and Time Mode, and Time Mode will step through the Time options, but the Trip mode remains locked where the B meter should be with the line as show in the photo. it will not toggle between A and B or the odometer.

The Trip Set and Trip/Time Set buttons provide no response when pressed. I cannot even get it to show the normal master total mileage odometer. Can it be reset or can the button contacts be cleaned?

It worked great for years, and I have the Factory Manual and have used the flow chart guide in the past with success, but no Joy in the current configuration.

Is there a magic master reset procedure, or any reset. for the dash (anyone)?

TIA

 

20140510_132531_zps5f70322a.jpg

Share this post


Link to post
Share on other sites

You keep pressing MODE Trip to cycle between trips A/B and ODO. SET Trip will clear trips A/B. No master reset I know of. Try disconnecting the battery for a bit and see what happens.

Edited by bmwpowere36m3

Share this post


Link to post
Share on other sites

Got a manual?

 

 Yes. The flow chart has always worked before, but not this time.

 

Have you ever had the display read no "B" to denote the meter like in the photo, and have you corrected it (and better yet can you tell us how you corrected it)?

 

 

Got a hammer?

 

Yes, a DRZ hammer :D .

  • Like 1

Share this post


Link to post
Share on other sites

You keep pressing MODE Trip to cycle between trips A/B and ODO. SET Trip will clear trips A/B. No master reset I know of. Try disconnecting the battery for a bit and see what happens.

 

TRIP MODE takes me to the display in the photo. In this state, none of the other buttons will change the display.

 

TRIP TIME will toggle through the time functions.

 

Has anyone encountered a display in this state?

  • Like 1

Share this post


Link to post
Share on other sites

TRIP MODE takes me to the display in the photo. In this state, none of the other buttons will change the display.

 

TRIP TIME will toggle through the time functions.

 

Has anyone encountered a display in this state?

 

Okay, once in that display "Trip A 116.6      _____ 100" if you press TRIP Mode again what happens, nothing? That display looks like the Trip Meter Adjustment, page 25 in my owner's manual.

 

Again I would try disconnecting the battery for 10 or so minutes, reconnect and try again.  Do the other buttons (SET Trip & Time/Trip, Adjust + & -, and Select) work in the other modes (setting clock, stop watch, timer)?

 

Maybe one of the buttons is stuck and setting you into a certain "mode".  You can take apart the cluster and check the buttons aren't making contact when they are not depressed (they are rubber and kind of spring-loaded).  Also check for any visual defects (burnt traces, bulging capacitors, lifted components, etc…) in the PCB or components (resistors, capacitors, ICs).

Share this post


Link to post
Share on other sites

Okay, once in that display "Trip A 116.6      _____ 100" if you press TRIP Mode again what happens, nothing? That display looks like the Trip Meter Adjustment, page 25 in my owner's manual.

 

Again I would try disconnecting the battery for 10 or so minutes, reconnect and try again.  Do the other buttons (SET Trip & Time/Trip, Adjust + & -, and Select) work in the other modes (setting clock, stop watch, timer)?

 

Maybe one of the buttons is stuck and setting you into a certain "mode".  You can take apart the cluster and check the buttons aren't making contact when they are not depressed (they are rubber and kind of spring-loaded).  Also check for any visual defects (burnt traces, bulging capacitors, lifted components, etc…) in the PCB or components (resistors, capacitors, ICs).

 

The battery disconnect worked. I pulled the negative terminal and left it off while I worked on other items for a few hours, and when I hooked it back up the dash reset. All the buttons now work as they should, and the same as they worked in the past. Whatever locked it up is resolved.

 

Thanks!

  • Like 2

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×