Jump to content
Sign in to follow this  

2008 kx250f missing low rpm torque

Recommended Posts

So I was riding around on my 2008 kx250f and I noticed when I go into first gear and really go on the throttle, it doesn't pull like I expect it to. I cleaned the air filter new jets in the carb new oil and spark plug. Anyone have any idea what it could be? It might just be in my head but I'll have to find out by riding a couple different bikes.

Thanks for any input!

Share this post


Link to post
Share on other sites

Did it pull before or is the bike new to you ?

 

It could be the leak jet that is to big which regulates the amount of fuel from the accelerator pump back to the float bowl, by fitting a smaller leak jet you will get more fuel into the cylinder to help with the big throttle openings at low revs.  

Share this post


Link to post
Share on other sites

Stock exhaust? Or after market check header bolts if they are loose it can mess with the back pressure and you can lose some power. Also valves could be a little outta spec seems like valves always play a role in almost every problem someone has like that. And maybe your back tire is spinning when you get on it so you're not feeling all the torque it has it's a long shot but just a thought.

Yz125

Kx250f

Share this post


Link to post
Share on other sites

The valves we're all to tight but I changed that. Exhaust is all good because I hear no popping.

I could try that leak jet. I have a JD jet kit I. There but I'm not sure if it changed the leak jet. Again it could be all in my head I have no idea haha

Thanks for the feed back guys

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×