Jump to content
Sign in to follow this  

Studs for oil filter cover came off...Loctite?

Recommended Posts

the studs for my oil filter housing came out with the nuts, and one nut is stripped. I have replacement ones on the way, with the though of loctiting them in, but...what loctite should be on the studs, and what loctite should be on the nuts? Thanks, gathering up needed parts today.

 

*edit: I read the loctie fixes in the FAQ, but nothing is mentioned of the oil filter housing cover... is this treated the same as the starter cover?*

Edited by Ivan-the-hunter

Share this post


Link to post
Share on other sites

I would think that you would probably want strong (red) for the studs and maybe medium (blue) for the nuts.

Share this post


Link to post
Share on other sites

Only loctite the studs with medium or high-strength threadlocker.... there only 6 mm and don't get much torque. Definitely don't loctite the nuts, snug with a 1/4" drive is all they need.

  • Like 1

Share this post


Link to post
Share on other sites

Loctie the studs to the case.  Use a double nut technique to turn them in fairly tight.  No Loctite on the nuts.  Light snug is all that is needed for torque.

  • Like 1

Share this post


Link to post
Share on other sites

Red loctited mine and they have been good for the last few oil changes.

Edited by rraiderr

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×