Jump to content
Sign in to follow this  

yz 125 wont start

Recommended Posts

I bought a used 98 125 off a guy who blew out the top end. He score the jug and piston. So i went ahead and bought a used 55mm bored jug with piston to match. They were used and the bore measured 55.08mm.

 

I just finished the rebuild with new gaskets, new oil, coolant etc. Second kick, it started for a second with choke open, then died.

 

I havn't been able to get it going since. 

 

Pulled the plug, had spark, replaced the plug anyway. Everytime i pull the plug, its wet with fuel. 

 

Went and got a compression tester, and it reads 135psi. Not the best, but better than most. 

 

I am not sure what else to do? Can anyone help me out

Share this post


Link to post
Share on other sites

Double check your timing on the stator side. Make sure the stator is lined up with the markings and that the flywheel is in slotted onto the crank correctly. Bike won't fire if its not sparking at the right time. Ensure the carb is in good shape and not clogged or floats stuck, if you pull the carb out, inspect the reeds and make sure there are no gaps and they open easily. Try a couple running pop starts and listen to the motor and see what that sounds like. 

 

If it still wont start and everything looks good, pull the motor out and inspect the head, make sure no gaskets popped out of there grooves and that the ring on the piston didn't move out of position. Sucks to have to pull the motor out again but figuring out what it isn't brings you closer to what it is.

Share this post


Link to post
Share on other sites

she started and runs great!

Turns out it was flooded. Pulled the plug and kicked many many times, then fresh plug and first kick, she purrs

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×