Jump to content
Sign in to follow this  

pw50 runs great with choke on... w/o not so much?

Recommended Posts

Got the kids PW 50 out this weekend for the first time in months. We have not had the bike long and have very little time on it. Bought it used but it looks to be barely used and all original. Anyways like I said it runs great with the choke on  but turn it off and it is very unresponsive. won't idle and eventually dies. Tried adjusting the air screw and idle w/o much luck. I have messed with the govenor and slack adjuster in the throttle cable  in an effort to tame her down for the little guy. ANy advice or pointers on this one?

Share this post


Link to post
Share on other sites

I suggest cleaning the carburetor.... If gas sits in the carb for months it will gum up and make a bike run like poo! But yeah, try cleaning the carb. :thumbsup:  

Share this post


Link to post
Share on other sites

Yes, clean the carb. When a bike only runs with the choke on it is a pretty good indication that the pilot jet is clogged. (Turning on the choke is compensating for the clogged pilot circuit). One of the most common ways for the pilot to become clogged is to leave gas in the carb for a few months.

Share this post


Link to post
Share on other sites

I had the same problem with my daughters PW 50 not too long ago. Pull the pilot jet out of the carb and simply snip a wire off of a wire brush and push it through the jet. This should do it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×