Jump to content
Sign in to follow this  

04 KX250F BOGGING, I PULL THROTTLE FAST AND BOGS. IF I DON' ITSLOWLY IT DOES JUST FINE

Recommended Posts

SO MY DIRTBIKE STARTED WITH BOGGING PROBLEMS AGAIN. :banghead:  IT IS ANNOYING FIRST TIME IT STARTED DOING THAT I TOOK OFF THE CARB CLEANED IT OUT AND WAS GOOD. IT HAS A R&D ADJUSTABLE ACCELERATOR PUMP. SO ALL OF THE SUDDEN IT STARTED DOING THAT AGAIN!! SO I TAKE OFF CARB CLEAN IT OUT, PUT IT BACK ON AND IS STILL BOGGING!! CABLES ARE OK, CARB IS CLEAN FUEL MIX SCREW IS ADJUSTED TO 2.5 TURNS. I HAD THE VALVES DONE HAS NEW SEATS THEY WERE CUT. ONE THING I DID NOTICE , I TOOK THE AIR BOX OFF FROM THE CARB SO I CAN SEE WHAT IS GOING ON THERE, NOW I DONT KNOW IF IT IS NORMAL BUT WHEN I PULL THE THROTTLE FAST IT SPITS OUT GASOLINE OUT OF THE AIR BOX SIDE OF THE CARB????? :excuseme:  

Share this post


Link to post
Share on other sites

Your accelerator pump diaphragm and passages are corroded

Clean and replace

If you are using pump gas, you better start treating it, or this will continue to happen

Share this post


Link to post
Share on other sites

I cleaned every single passage on accelerator pump,float bowl,jets, except for the choke and hot start.

Edited by jorgemmartinez6509

Share this post


Link to post
Share on other sites

OK this is what I did. I noticed that the accelerator pump wasn't putting enough gasoline into the chamber. It was a squirt on and off. so I noticed that, got diaphragm and accelerator pump. I put diaphragm in accelerator pump without the spring. I put letters facing down it didn't seem like it would give out enough pressure to pump the gas.(LETTERS OF DIAPHRAGM ARE SUPPOSED TO FACE THE STOCK ACCELERATOR PUMP) The middle part of the diaphragm was hitting the accelerator pump to soon I believe so what I did is i turned around the diaphragm the other way(LETTERS FACING THE CARB) seemed like it would give more pressure to pump gas that way. I put it back together I pull throttle and it PUMPED A CONTINOUS SQUIRT so It  I thought that it was better pressure. I turn on my bike start revving.......and ITS GOOD BOGGING STOPPED COMPLETELY RESPONDS PERFECTLY!! I didn't install this pump came with the bike when i bought it. It was bogging since I got it. It is a relief. maybe it was meant to be done that way or this after market pump came with a diaphragm and other owner didn't follow instructions or something I will do some research  on it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×