Jump to content

Rear brake won't gain pressure after rebuild?

Recommended Posts

I would post in model specific fourms but this is a pretty general problem. A brake is a brake.

So the rear brake fluid on this bike was black. I flushed them, and it wouldn't gain pressure. So I rebuilt the master cylinder, and put it back together. Still no pressure. I replaced the bleeder screw and got a Tusk hydraulic bleeder, again with no luck. But some weird things are happening that are showing that fluid is moving. When I take off the hydraulic bleeder and pump the pedal fast some fluid spurts out, then stops. So I took the caliper off and held it high in the air, because air goes to the highest point. Pumped pedal. No luck. So I made the master cyl the highest point, and pushed the brake piston in quickly. Some air bubbled up into the master cylinder, so I started pumping again with no luck.

Any words? We need this bike for a trip friday and the weekend would suck if it didnt work right. Help!

Share this post


Link to post
Share on other sites

Have they been bled properly? Sounds like air in the line if no fluid comes out. Put new fluid in, press down, close the line, and depress the pedal, otherwise you'll just suck more air in when you press it.

Share this post


Link to post
Share on other sites

Have they been bled properly? Sounds like air in the line if no fluid comes out. Put new fluid in, press down, close the line, and depress the pedal, otherwise you'll just suck more air in when you press it.

No. They will not bleed. Sorry if that wasnt clear.

Share this post


Link to post
Share on other sites

Oh, alright then. Bleed at the banjo bolt as he said above, and make sure fluid is actually going through the line. There was no debris in the master cylinder or anything when you rebuilt, or was it spotless. Why you rebuild it anyways?

I can only imagine the fluid is blocked by some dirt/debris that got in the line. And is the caliper functioning properly?

Share this post


Link to post
Share on other sites

Oh, alright then. Bleed at the banjo bolt as he said above, and make sure fluid is actually going through the line. There was no debris in the master cylinder or anything when you rebuilt, or was it spotless. Why you rebuild it anyways?

I can only imagine the fluid is blocked by some dirt/debris that got in the line. And is the caliper functioning properly?

Master cyl is clean. I rebuilt it because the brakes wouldnt gain pressure after I went to flush the fluid.

Caliper works fine.

Share this post


Link to post
Share on other sites

They likely just need to be bled. Spend $5 and acquire a 60cc syringe. Then google "reverse bleed"...

Like I said before. They will NOT bleed. But I will look into reverse bleed.

Share this post


Link to post
Share on other sites

Like I said before. They will NOT bleed. But I will look into reverse bleed.

You didn't change anything, just fluid....then there was no brake pressure. VERY high likelihood that you introduced air...

25+ years of working on sleds, trikes, quads, and bikes. MANY times the brakes would "not bleed" by conventional means. A quick reverse bleed and instant brake pressure.

I have trouble buying that the brakes will not bleed, but it wouldn't be the first time I was wrong...

Edited by Fattonz
  • Like 1

Share this post


Link to post
Share on other sites

I usually put a little back pressure on the bleed screw with my finger to jump start a difficult master cylinder.  It must help balloon the seals in the master so they work better.  Masters usually have two cup seals, the one with the little lines on it goes closest to the fluid if I remember correctly.

Share this post


Link to post
Share on other sites

You didn't change anything, just fluid....then there was no brake pressure. VERY high likelihood that you introduced air...

25+ years of working on sleds, trikes, quads, and bikes. MANY times the brakes would "not bleed" by conventional means. A quick reverse bleed and instant brake pressure.

I have trouble buying that the brakes will not bleed, but it wouldn't be the first time I was wrong...

They really wont bleed. As fake as it sounds, im serious, they just wont go.

Reverse bleed it is.

Share this post


Link to post
Share on other sites

If the fluid was black and they will not bleed.... Debris in the line? I agree with the syringe and shoot fluid up (reverse bleed). If it will not come through .. It is blocked.

Share this post


Link to post
Share on other sites

If the fluid was black and they will not bleed.... Debris in the line? I agree with the syringe and shoot fluid up (reverse bleed). If it will not come through .. It is blocked.

 

+1....I'm thinking blockage as well.  I have had it where the blockage is close to the bleed nipple and no way could I inject fluid with my syringe....the hose would just blow off the nipple.  I would then switch to a vacuum pump and see some crap get drawn out....at that point I go back to reverse bleed using the syringe....and voila....brake pressure :)

 

It's just weid that you were able to successfully change fluid if a blockage exists....

Edited by Fattonz

Share this post


Link to post
Share on other sites

Hello, I made a post yesterday about the rear brakes not getting pressure. Not a model specific thing really.

Anyway, rebuilt the master cylinder. Bled brakes...no pressure still. So I reverse bled them too. Correctly. Still nothing, but the brake piston moves a little bit. So I got some vice grips on it and pulled it out a bit more while pumping the pedal. Eventually it stopped moving all together. WTF!

HELP!!!

Share this post


Link to post
Share on other sites

I had this problem with my 09 KTM front brake. It was an air pocket that wouldn't get out of the caliper until I flipped it upside down and bled it that way. I was using a vacuum bleeder, I tried the reverse bleed, tried the zip tie over night to build pressure, nothing worked until I flipped it upside down with the help of a buddy to get it done. It was actually his recommendation that lead me to the fix.

 

Worth a shot, but if everything is good, it's air that is trapped and won't come out.

Share this post


Link to post
Share on other sites

I had a similar issue with my rear brake after replacing the lines. I could not get any brake fluid at the bleed nipple no matter how long I pumped. The solution was to pull a vacuum on the bleed nipple an suck the fluid through the lines. You can either use a mitivac or you can create a vacuum with your mouth and a rubber hose attached the the bleed nipple. Once you get some fluid out of the nipple you can revert to the typical methods of bleeding brakes by pumping up the lever and cracking the bleed nipple.

Share this post


Link to post
Share on other sites

Brake fluid flows freely. No blockage anywhere, hell, im almosy positive no air either. I reverse bled 4 times with expected results, but still no pressure.

Dont worry about it guys. Ill figure it out...or rather, the local shop will. Thanks.

Share this post


Link to post
Share on other sites

I use one of the old fashioned oil cans with a pump lever and spout like the tin man used in the Wizard of Oz. Attach a fuel line from the spout and connect it to a slightly loosened bleeder bolt and pump it in backwards. You have air somewhere it sounds like.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×