Jump to content
Sign in to follow this  

Kx500 jetting problems?

Recommended Posts

I just bought a 94 Kx 500 it has just had the top end done and replated and is bored to a 510 and has an fmf full exhaust and I am having trouble getting it to run correctly. It's got a keihin 39mm pwk carb with a 180 main and a 58 pilot. The needle clip is in the #2 position. It runs really well until it begins to get into the power band, then it breaks up and feels as if it is leaning out. The jetting seems a little rich to be leaning out and I'm all out of ideas. I have tried the air screw from just 1 turn all the way to 5 turns out without any noticeable difference. I'm 200 ft above sea level. I run a 32:1 castor 927 premix in 50/50 pump gas/race gas. Any help getting this beast running correctly would be much appreciated. Thank you.

Share this post


Link to post
Share on other sites

I am happy to report that I solved the problem with y'all's help. Before I did an engine leak down test I decided to move the needle clip down to the middle and eventually down to the very bottom slot. Every clip position change duplicated the results I had before when I had the needle in the #2 slot except worse in every way. The farther I went down the needle the worse it got. It bogged earlier and more often, had excessive smoke out of the tailpipe, etc. This obviously tells me I have been running way to rich and that I need to lean out on the jetting. Thanks for the help!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×