Jump to content
Sign in to follow this  

125L Dies When Giving Gas

Recommended Posts

Hi guys,

I have a 2007 TTR125L that I bought 3 years ago with very low hours (at the time it has quite a bit more now). Never had a problem with it until today. It starts and idles great but when I give it gas it dies even after it's warm. When I put it in first and try to accelerate, it dies.

My husband and I put in a fresh spark plug and had the same problem. Then we checked the carb and a fair amount of fuel poured out so we thought it was just flooded. Tried to start again and same problem when giving gas. We are going to try running some carb cleaner through and see if that helps.

Only after market part is an FMF Powercore 4 which I've had on it since I purchased the bike. No other mods. Recent maintenance is an oil change, cleaned and reoiled the chain, and new back tire.

Any other ideas?

Share this post


Link to post
Share on other sites

Was the bike sitting around for a while and you are now wanting to ride it after it sat?

If so, it's probably the pilot jet in the carburetor plugged-up from stale fuel remnants.

 

I'd service the air filter, too.

Share this post


Link to post
Share on other sites

I'd bet on the pilot jet as well. I've never had a bike that the pilot jet gets clogged on as much.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×