Jump to content
Sign in to follow this  

Why don't my brakes work

Recommended Posts

I just changed the rear brake pads on my 2012 450 and now the brakes don't work. I checked the fluid and I even tried to bleed the brakes but I still have nothing. When I was trying to bleed the brakes I was not getting any fluid out of the bleeder. What could be my issue?

Share this post


Link to post
Share on other sites

Use a syringe and reverse bleed the brakes. This seems to be the most effective method with the KTM's. I reverse bleed the fronts, rear, and clutch and never have a problem.

  • Like 1

Share this post


Link to post
Share on other sites

Use a syringe and reverse bleed the brakes. This seems to be the most effective method with the KTM's. I reverse bleed the fronts, rear, and clutch and never have a problem.

+1 with the reverse bleed. Not just effective on ktm but it works on every single bike.

Share this post


Link to post
Share on other sites

I have never touched the pedal height but the brakes worked fine before I changed the pads. I put the syringe in the bleeder and basically bleed the brakes?

Share this post


Link to post
Share on other sites

I have never touched the pedal height but the brakes worked fine before I changed the pads. I put the syringe in the bleeder and basically bleed the brakes?

Yes. Make sure you get all the bubbles out of the syringe and hose. Open the bleeder screw and push the fluid in. Use the syringe to suck fluid out of the master cylinder and repeat.

Share this post


Link to post
Share on other sites

Just a question, why did you change the pads? Possibly there was air in the line, making the pedal spongy?

Just reverse bled my rear brakes today after cleaning up my bike after a ride today. Like the other guys have said this is the most efficient way to get any trapped air out.

Share this post


Link to post
Share on other sites

The pads were really worn out and it was time for new ones. I am going to try it out tomorrow and see if I can get it

Share this post


Link to post
Share on other sites

I just changed the rear brake pads on my 2012 450 and now the brakes don't work. I checked the fluid and I even tried to bleed the brakes but I still have nothing. When I was trying to bleed the brakes I was not getting any fluid out of the bleeder. What could be my issue?

Did you get your rear brake figured out? Just curious what it was.

Share this post


Link to post
Share on other sites

I opened the reservoir and took out the rubber sleeve. I could not get it to bleed or work but when I put the sleeve back in they just started to work

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×