Jump to content
Sign in to follow this  

I need help! YZ250F

Recommended Posts

Alright guys I am freaking out! I went out to the track today and last night I had to scramble around and change my oil and filters. The bike ran awesome and I was flying at the track, but after I got the bike home and washed it I tried to start it, and nothing happened. I tried to bump start it, MULTIPLE TIMES. The didn't work either, so I looked down at my oil sight glass and there was hardly any oil! (YES, I changed my oil the night before and put the oil filter in right) The bike is a 2007 YZ250F. Is there like a sensor or something on this bike that permits it from turning over if it is low on oil? Also, what may have caused me to loose so much oil? I have no leaks on the head, cylinder, or valve head. I am freaking out and I really need help. I drained what was left in the bike, and the oil was brand new and didn't have any metal shavings. You could eat out of the cylinder its that clean. The spark plug has a blue spark and it wasn't making any weird noises at the track. Please help! thanks!

Share this post


Link to post
Share on other sites

My 2010 YZ450 oil sight glass shows empty until engine heats up, is 07250f the same? How much oil came out when draining?

Share this post


Link to post
Share on other sites

Not sure about not starting up, but with the oil level let me ask you a few things. When you drained the oil out you also drained the oil reservoir and changed out the filter? Ok now if you just put oil back into your bike at this point and just go by the oil sight line and leave it at that you'll be low on oil.  Once you start up the bike and run it a bit the oil will circulate into the reservoir and absorb into the new filter then you wait a couple of minutes after you shut it off and your reading will be true and will show low, add some up to the appropriate level or find out how much oil your bike takes with a new filter and add it that way. If you did this and now it's showing low after being correct you have a different problem. 

Share this post


Link to post
Share on other sites

There's a neutral switch or something like that... Can't remember what it's called. It will shut the bike off if the oil gets too low. My bike 09 yz250f had a stripped oil tank breather bolt so when I rebuilt my whole motor I put a wet sump kit on it which pretty much deletes the oil tank and there's a neutral switch block off in the kit which allows the motor to run on 850cc of oil, which the switch would think it's too low.

Share this post


Link to post
Share on other sites

Bike needs 3 things to run, fuel, compression and spark, is it getting fuel, is fuel getting to the carb, take the fuel hose off and check it is running?, is the plug wet when you take it out? When you kick it dies it feel like it has the same resistance as normal? If you think something is up check your timing and valve clearances. Don't be scared to try a new plug, I have had a couple that spark outside the cylinder (weird spark all over the place) but wont get motor started.

If you put the correct amount of oil in the motor (measure it, don't use the sight glass) then you have the corect amount in there, unless you see somewhere it has leaked out! The glass only gives an indication that it has oil in it. There are people that say they never get the same amount out as they put in, do they think that it is hiding in there and getting more full everytine they do an oil change? I have never heard if a level sensor on a yz or wr, mate of mine rode his down the street before he realised it had not been filled after oil change, no oil - not just low oil.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×