Jump to content
Sign in to follow this  

Yz125 running extremely hot :(

Recommended Posts

Can't figure out all of a sudden it is running really really hot it burns your finger tips to touch the cylinder why is that anybody have answers to fix that it never used to do that just all of a sudden

Share this post


Link to post
Share on other sites

Can't figure out all of a sudden it is running really really hot it burns your finger tips to touch the cylinder why is that anybody have answers to fix that it never used to do that just all of a sudden

Have you checked your coolant level?

Share this post


Link to post
Share on other sites

Make sure a hose isn't kinked. Your bike doesn't like kinky hoes :naughty:

  • Like 3

Share this post


Link to post
Share on other sites

How old is the bike? other then checking the obvious things mentioned it could the raditor cap has gone out or wrong type of coolant and you clogged up your raditors doubt it is an air bubble in the coolant passage.

Share this post


Link to post
Share on other sites

Coolant circulates good and impeller spins freely what else could it be

First off you need to help us and give a better description of the basic issue. "my bike all of a sudden runs hot what's wrong with it" doesn't help us. We are not looking at your bike we are looking at a computer screen. First check all the BASICS. Is the coolant full ? Is the radiator clean and not clogged with mud ? Any wet spots around the engine ? Did you possible overheat the engine by too much slow speed riding in mud ? You might have a blown head oring.

Share this post


Link to post
Share on other sites

Do you leave it to.Idk for a half hour then try it? Does it spew coolant out the overflow while it's that hot?

I go about 2 miles and it smells like it's gonna catch fire and no it doesn't spew it put

Make sure a hose isn't kinked. Your bike doesn't like kinky hoes :naughty:

hoses are good

How old is the bike? other then checking the obvious things mentioned it could the raditor cap has gone out or wrong type of coolant and you clogged up your raditors doubt it is an air bubble in the coolant passage.

2002 cap might be bad idk how can you tell and rads are clear not clogges

Share this post


Link to post
Share on other sites

First off you need to help us and give a better description of the basic issue. "my bike all of a sudden runs hot what's wrong with it" doesn't help us. We are not looking at your bike we are looking at a computer screen. First check all the BASICS. Is the coolant full ? Is the radiator clean and not clogged with mud ? Any wet spots around the engine ? Did you possible overheat the engine by too much slow speed riding in mud ? You might have a blown head oring.

coolant full clean rads no wet spots not much mud riding and I just put new head orings in not even 1 hr of riding ago

Share this post


Link to post
Share on other sites

Then I would tell you that you need to go buy some new head o-rings and make sure you didn't pinch the o-ring and be absolutely certain nothing is blocking coolant passages or that your not sucking in coolant through the head. You don't have the tool for testing raditor cap but over time they can loose thier pressure the spring wears out usually it starts to wanna puke out the over flow tube.

 

Otherwise all answers point to you messed something up doing the rebuild.

Share this post


Link to post
Share on other sites

I go about 2 miles and it smells like it's gonna catch fire and no it doesn't spew it put

hoses are good

2002 cap might be bad idk how can you tell and rads are clear not clogges

If you're overheating, but it's not making its way to the top of the editor it's probably not circulating. Check the water pump

  • Like 1

Share this post


Link to post
Share on other sites

If you're overheating, but it's not making its way to the top of the editor it's probably not circulating. Check the water pump

how will I know if it is broken I took it apart and it looked good

Share this post


Link to post
Share on other sites

Sounds kinda like shes runnin lean. Whats the last thing u repaired on it?

Orings in the head

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×