Jump to content
Sign in to follow this  

I need help concerning my YZ250F

Recommended Posts

Alright guys I am freaking out! I went out to the trackicon1.png today and last night I had to scramble around and change my oil and filters. The bike ran awesome and I was flying at the track, but after I got the bike home and washed it I tried to start it, and nothing happened. I tried to bump start it, MULTIPLE TIMES. The didn't work either, so I looked down at my oil sight glass and there was hardly any oil! (YES, I changed my oil the night before and put the oil filter in right) The bike is a 2007 YZ250F. Is there like a sensor or something on this bike that permits it from turning over if it is low on oil? Also, what may have caused me to loose so much oil? I have no leaks on the head, cylinder, or valve head. I am freaking out and I really need help. I drained what was left in the bike, and the oil was brand new and didn't have any metal shavings. You could eat out of the cylinder its that clean. The spark plug has a blue spark and it wasn't making any weird noises at the track. Please help! thanks!

Share this post


Link to post
Share on other sites

Maybe you just rode all the oil out of it. I do that sometimes cuz im so fast.

I dont feel like answering seriously, but no, no oil sensor.

Water is probably your culprit right now.

 

Id probably put oil in it and turn the gas on, though, too.

Edited by jeffdanger

Share this post


Link to post
Share on other sites

Maybe you just rode all the oil out of it. I do that sometimes cuz im so fast.

I dont feel like answering seriously, but no, no oil sensor.

Water is probably your culprit right now.

 

Id probably put oil in it and turn the gas on, though, too.

Can that actually happen? I'm really stressed about this because I race in a series that goes all around Florida and without my bike, I cant race. I need honest answers

Share this post


Link to post
Share on other sites

Can that actually happen? I'm really stressed about this because I race in a series that goes all around Florida and without my bike, I cant race. I need honest answers

Did you add oil into filters, or put filters in dry then oil in sight glass topped off then Ride with out retopping it after warm up?
  • Like 1

Share this post


Link to post
Share on other sites

Can that actually happen? I'm really stressed about this because I race in a series that goes all around Florida and without my bike, I cant race. I need honest answers

Ha. No im jk about riding all the oil out of it.

I wouldnt get too stressed, with a little patience youll be back on the road.

Usually a no start after a wash is due to water somewhere. 

You could try checking your intake for water, draining your float bowl, double checking your oil level.

  • Like 1

Share this post


Link to post
Share on other sites

Did you measure how much oil you put in when you changed the oil or did you just pour to the sight glass? I believe the 07 has an oil tank in front or the engine. If you just filled the oil to the sight glass and that's it then you didn't put bear enough oil in

  • Like 1

Share this post


Link to post
Share on other sites

Did you add oil into filters, or put filters in dry then oil in sight glass topped off then Ride with out retopping it after warm up?

I added oil to the filters and topped off sight glass then just went and rode

Share this post


Link to post
Share on other sites

Ha. No im jk about riding all the oil out of it.

I wouldnt get too stressed, with a little patience youll be back on the road.

Usually a no start after a wash is due to water somewhere. 

You could try checking your intake for water, draining your float bowl, double checking your oil level.

I drained all the oil and no it is just sitting. what else should I do?

Share this post


Link to post
Share on other sites

I drained all the oil and no it is just sitting. what else should I do?

now

 

Did you measure how much oil you put in when you changed the oil or did you just pour to the sight glass? I believe the 07 has an oil tank in front or the engine. If you just filled the oil to the sight glass and that's it then you didn't put bear enough oil in

I did put the correct amount of oil in yes

Share this post


Link to post
Share on other sites

I added oil to the filters and topped off sight glass then just went and rode

There you go.

Add to sight glass, warm up bike a few minutes, then shut off, let set another few minutes, top off again.

Then ride.

Its not a 2t. My 450 did same thing.

I set to sight glass. Was low next day after ride.

Share this post


Link to post
Share on other sites

now

 

I did put the correct amount of oil in yes

You didn't answer the question.  If you just filled it to the sight glass and and let it rip then you severely under-filled your oil.  Your bike has an oil tank that does not get filled just by poring oil into the engine.  you need to put oil in the engine,  start and warm it up allowing it to fill the oil tank,  then shut it off and fill again.

  • Like 1

Share this post


Link to post
Share on other sites

There you go.

Add to sight glass, warm up bike a few minutes, then shut off, let set another few minutes, top off again.

Then ride.

Its not a 2t. My 450 did same thing.

I set to sight glass. Was low next day after ride.

like how low man and mine is a 4t

Share this post


Link to post
Share on other sites

You didn't answer the question.  If you just filled it to the sight glass and and let it rip then you severely under-filled your oil.  Your bike has an oil tank that does not get filled just by poring oil into the engine.  you need to put oil in the engine,  start and warm it up allowing it to fill the oil tank,  then shut it off and fill again.

ahhhhhhhh ok cause I normally do do that, but like I said I was in a rush the night before and I don't think my neighbors like my fmf pipe at 10:30 PM and i checked the oil and filter. there was no shavings. would you say that i am good?

  • Like 1

Share this post


Link to post
Share on other sites

Not until you put the oil and filters back in!

ok well with today being Memorial Day, ill get some tomorrow... New oil and oil filter, put it in, warm it up and top it off again right?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×