Jump to content
Sign in to follow this  

front speedometer thing 91 xr250l

Recommended Posts

Hi all,

 

I just installed a new tire on the front wheel and upon reconnecting the speedometer cable to the little black housing thing and tightening down the fine threaded screw the housing of the thing cracked and no longer holds the cable in place.

 

Now my speedometer doesn't work either. It worked prior to doing this so I can only assume it's not working because the housing is now cracked (I can just pull the cable out by hand with the screw all the way in in).

 

Has anyone done this before? Would it simply be this which is causing the speedometer not to work, or would it be something inside the assembly of that black thing? I'm thinking I could probably just epoxy the housing back together to make me able to put the screw back in to secure the cable.

 

If not, where can I get one of these things for cheap? I found them online but it was like $100!!!

Share this post


Link to post
Share on other sites

Can you fit a clamp on it temporarily to confirm if it's the crack causing the problem?

 

Should be able to find a replacement on ebay.  Several XR models around that vintage used the same part #.  Double check for compatibility on service honda.

Share this post


Link to post
Share on other sites

Ok I'll have to try that. I've been having a hard time trying to get the bike up off its front wheel because I don't have a proper motorcycle stand. Gonna have to see if my bigger jack in storage extends high enough to lift the bike up under the engine/frame. Don't have $100 for a proper bike jack/stand heh.

Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×