Jump to content
Sign in to follow this  

Crf 450 2010 Starting issue..

Recommended Posts

Hey

 

Wont start cold installed new inlet valves and all valve clearners is OK. Have to tear it behind the car before it stars

but when it starts the red light on kill switch starts plinking and stars on dime wen hot the issue was there before i checked valves.

Cleared the fuel filter and poked all connectors maybe i missed some i am out of ides what that might be. Don't  have the manual

to check what that plinking means if you have any ides please let me know thanks any help is welcome...

 

Thanks

Share this post


Link to post
Share on other sites

You have an error code detected. What is the blink sequence in long and short blinks? There may be more than one sequence blinking.

Share this post


Link to post
Share on other sites

You have an error code detected. What is the blink sequence in long and short blinks? There may be more than one sequence blinking.

It blinks continuously the blink is like half a second long and the light stays of to like half a second

 

Thanks 

Share this post


Link to post
Share on other sites

my2010 has a code after i put a new stator and condensor in it. i think mine is showing the map code it blinks 2 times after the light goes out when it is started. these fuel injected bikes can be a pain

Share this post


Link to post
Share on other sites

Constant blink is prolly a sensor unplugged like ect or iat in the airbox

checked and cleaned both but no good if you have any idea what else might they be let me know. but yeah makes sense that continues blink might be something unplugged..

 

thanks

Share this post


Link to post
Share on other sites

1 short blink. Is a MAP sensor circuit malfunction.

Share this post


Link to post
Share on other sites

Its normal for the MIL to blink on start. There is a code detected if it keeps blinking while the engine is running.

Share this post


Link to post
Share on other sites

Finally got it started and there is some kind of code the red light blinks seven times and then there is a pause about  three seconds and it blinks again 

and keeps doing that continuously..

 

Thabks

Share this post


Link to post
Share on other sites

7 blinks is an "ECT sensor circuit malfunction" the book says this will cause "hard start at a low temperature" . The ECT sensor is the one that goes into the cylinder head just below and to the right of the throttle body.

Edited by nzgsr

Share this post


Link to post
Share on other sites

7 blinks is an "ECT sensor circuit malfunction" the book says this will cause "hard start at a low temperature" . The ECT sensor is the one that goes into the cylinder head just below and to the right of the throttle body.

Thanks    

 

I guess that what it is it starts terrible when cold ...

 

Cheers

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×