Jump to content
Sign in to follow this  

Question regarding 2014 RMZ-450

Recommended Posts

So I just purchased a brand new 2014 from the Suzuki dealer. I bring it home and I get it started by pulling the starter knob. Let it warm up and it idles really high. I have tried turning the knob to slow the idle. But it has no effect. And when I push the knob in. The bike dies immediately. Has anyone had this issue or know how to remedy this. I turned the fuel screw to factory recommendations of 6 clicks counterclockwise from completely clockwise. First time with EFI so maybe I'm not doing something right. Need help. Thx.

Sent from my iPhone

2014 RMZ-450

Share this post


Link to post
Share on other sites

Take it back and make them fix it... it's a brand new bike. Don't mess with it too much before then. Don't accept the bike back until you are satisfied.

Share this post


Link to post
Share on other sites

Ok yeah I was going to do that with dealership but if it was something really simple I would just do it instead of bringing back.

Also thx. Good idea. I will post in there.

Sent from my iPhone

2014 RMZ-450

Share this post


Link to post
Share on other sites

Even if it is a simple this or that .A brand new Bike with any prob's should go back ASAP before responsibility falls on you  . if the neglected to check one thing or the other , makes me wonder how far the oversight goes .

  • Like 1

Share this post


Link to post
Share on other sites

Yeah. I followed the startup procedure to the T. It's nice the new zukes come with a service manual so I did exactly that. I think I'm going to call the dealer tomorrow.

Sent from my iPhone

2014 RMZ-450

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×