Jump to content

Yfz450 no spark help?!

Recommended Posts

I just bought a yfz450. It's not getting spark to it. 2004 model. I have a parts bike and iv tired about everything. The guy I bought it from replaced the stator. I know all the parts from my parts bike are in good shape and work. I replaced the CDI, all of the TPS sensor stuff and I also tried bypassing it. The starter relay, the fuses on top of the battery, the coil, I'm not sure what else there is to do and why it's still not getting spark. Right now I'm thinking about just replacing the whole wiring harness but I wanted to see if anybody else had any ideas

Share this post


Link to post
Share on other sites

Possible grounding of starter switch? Meaning the on/off switch, could that possibly be stuck in, grounding it out causing a no spark issue? Something to think about anyway, maybe use an ohmmeter to make sure it's not faulty.

Share this post


Link to post
Share on other sites

Try a new Battery , I only have spark with new bat on a pol 500 scrambler  , pull start will only work with batt  . check all switches and grounds and fusses , take plug out and leave on coil wire and spend motor over with plug on side of block should see sparks , if not their is a resistor in the plug wire cap use screw driver take out connector , resistor and spring will fall right out , next replace with a nail , brass , screw , cut to same length , reinsert , and new plug  spend motor over again , I have done this to all my dirt bikes , no harm will come, If every has been replace , grounds check , and new fusses and no shorts , check with tester , I have seen many Bikes and 4 Wheelers , not have spark all Because OF THAT DAM RESISTOR .  Hope this Will help you out

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×