Jump to content
Sign in to follow this  

Smoke after repacking muffler. Two bikes 04 rmz 04 kxf. Help.

Recommended Posts

I picked up an 04 rmz 250 not running I got a used head everything seems fine I put it together got it running and idling runs great runs like a raped ape compared to my 04 kx250f not sure why that is though considering they have same motors. But my jx250f just staryed to smoke after my last practice day. Rmz after pack kind ng the myffler it smojed some but if it was only from the new packing it wouldve stopped right ? Smokes pretty bad for a four stroke. Piston looked like brand new. Cylinder was good why are tgese two bikes smoking how can I fix. Also I oiled the air filter but I didnt use any more oil then I do on my kxf. Any help here ?? With both bikes preferably. . Im personally thinking n ew piston and rings in the jx and just new rings in the rmz. Will or should this help or fix it ?

Share this post


Link to post
Share on other sites

Also for the one being faster kx is stock like not bored outvstock exhaust valves nothing fancy rmz is same as well. From what ive seen. Possible low compression ? Startd and runs pretty good is whyvi hadnt guessed that but could be valve adjustments are goodish on both

Share this post


Link to post
Share on other sites

on my old 04 rmz that rubber plug came out of the head because they didn't put a flanged bolt in that year. luckly I shut it off before I seized cams, but it burned up the valves, guides, and seals. Id pull it down and check everything over

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×