Jump to content
Sign in to follow this  

2002 Ttr-125 stopped and won't start

Recommended Posts

I have a 2002 ttr 125 and it just shut off after putting new gaskets in the top end because of a oil leak on top end.I think I put it all back together right... Well when I started it up it was making a weird ticking noise when I would ride it. I rode it about 15 min yesterday around the yard and started it up today and rode about 30 ft and it shut off. So I tried to kick start it again but when I kicked it it had NO compression. I took the cover off to get to the camshaft gear ( I think that's what it is called) and the bolt holding the gear on was loose. I tightened it back up, put the cover back on, tried to start it and still had no compression. What might it be? I am planing on going on a trip when school gets out in a week and riding with my old friends. I really we'd to fix this ASAP.

-thanks, phillip

Share this post


Link to post
Share on other sites

Sounds like the cam chain jumped on the sprocket! The ticking sound would be the cam chain tensioner not set right or possible valve stuck!

Reset the timing on the cam then rotate the engine by hand (spark plug out) and watch the valves move. If they don't you have more problems!

Share this post


Link to post
Share on other sites

Ya I took the engine back off and took the whole back end off again and could not find the problem... I decided I was done for the night so I put it back together and when I was putting the cam chain sprocket back on I realized that the lip on the sprocket that holds the sprocket onto the cam was broken. So I ordered a new one today. I'm shore that was the problem. Thanks for helping out a little

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×