Jump to content
Sign in to follow this  

99 Rm 250 carb issues

Recommended Posts

I have a 99 rm 250 I just rebuilt the top end and it runs like a raped ape tons of power starts first kick. I've had the bike for 5 years it's never ran so good.

I have a problem that is becoming a pain in my arse and I'm getting ready to sell the bike if I can't fix it. I had this issue before the rebuild the bike did s

I have a 42 pilot, 155 main, needle in the leanest pos.(highest on the needle), and fuel mix screw 2 turns out. This setup is where ther bike feels best so far. I have so much splooge it ends up all over the fender, swing arm, running down the tail pipe. I ride the bike pretty damn hard and I have never fouled a plug till recently seems to be every ride I foul one. And it seems to eat fuel like no tomorrow, 40 miles ish on a 3.2 gallon fuel tank. I used to be able to get closer to upper 60s. Bike also stops idling once warm.

Anyone have any ideas on what the problem might be? I have also replaced the needle and float. And clutch side crank seal.

I have tired this number of jets( 40-45 pilot, 155-160 mains)

Thanks for any help

Share this post


Link to post
Share on other sites

might be blowby.. i dunno you said you had the bike for 5 years and you had this issue before yet the bike runs great im kinda confused

 

if you're fouling plugs i think it might be blowby you changed the rings recently ? did you break in the top end cuz the rings have to be broken in where they should expand against the cylinder wall and squish the oil down into the crankcase

Share this post


Link to post
Share on other sites

I haven't had this problem the entire time I've owned it, it only seems to be getting worst. The bike sat for about a year after I put on the power core spark arrestor and ever since then it's ran rich as hell.(never fouled a plug till right before rebuild) so I did the rebuild and a bike builder told me I'd have to mess with the jetting anyway. I did kind of break it in, couple warm up cool downs. Half day of riding half throttle with a couple hard blips never keeping the rpms the same, then rode it like I stole it.

Share this post


Link to post
Share on other sites

Yes rings were replaced during the rebuild. It is baffling me as well that the bike can run so good and be as rich as it is. It doesn't make much sense I'm beginning to think my carb is just worn out.

Yes rings were replaced during the rebuild. It is baffling me as well that the bike can run so good and be as rich as it is. It doesn't make much sense I'm beginning to think my carb is just worn out.

Share this post


Link to post
Share on other sites

Try 1 and  1/2 turns out on the mix screw

 

158 main jet

 

put the carb needle clip in the 2nd position

 

and 48 pilot

 

mix at 40:1

Edited by 78SuzyQ

Share this post


Link to post
Share on other sites

Check the jet tower gasket inside the carb. Theres two hex screws next to the main jet when the bowl is off; remove them and pull out the jet tower. Underneath is a rubber gasket that goes bad and youll never get it to run right. Same symptoms youre having, I had and that gasket fixed it. Its $8 on jetsrus.com.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×