Jump to content
Sign in to follow this  

Need help please!

Recommended Posts

I was riding my Drz 400 on the freeway going about 70 then all of a sudden I felt a sputter and it just died. So I pulled over and tried to start the bike and it started right up no problem. When I give it throttle it just dies every time. Bike ran very solid before it died. Was riding it for about a year no problems. I would appreciate any help I can get here on this forum. Thanks

Jetted stock carb 165 mj 45pj

Rs3 yoshimura

3x3 mod

Share this post


Link to post
Share on other sites

Yeah I tried reserve and disconnected from the carb side fuel line to see if gas was flowing and it was. It's weird the bike starts up no problem but just when I give it gas it just cuts off. Bike is a 2k DRZ S

Share this post


Link to post
Share on other sites

Perhaps a chunk of something has made its way to the main jet, allowing  it too idle all day long but run above idle circuit?  Do you have a fuel filter installed? if not, maybe check main jet

  • Like 1

Share this post


Link to post
Share on other sites

HHHMMMM......not main jet then.  can the stock TPS sensor on carb affect timing so much that it won't run?  I wonder if unplugging the TPS on the carb would make any difference. also see if pulling choke helps any.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×