Need help!

I've recently replaced a radiator hose that was torn. I started my kx 125 and it started leaking lots of radiator fluid from the nuts on my cylinder head. I do have a damaged head gasket but didn't know if that had anything to do with it. If I can't figure it out I'm just gonna take it into a service shop, thanks.

Gasket/O-rings are bad or head not torqued properly. Depends on what your you have since you didn't state it in your post.

 

Most ppl think I'm crazy but my only torque wrench I use on my bikes cost $550. Just see your local Snap-on guy. He'll be happy to make sure you're doing it right.

Does it have the original acorn style nuts?...if not then it should..I dont have a $550 torque wrench..I just have 550 years of experience...8^)

No they are flanged nuts. The original schematic in Manuel shows flanged nuts. Should I get acorn style ones?

What year is it? I thought most all the bikes came with acorn nuts....but if it shows flanged then that is okay.

Just make sure the crush washers are good and the head seals..Make sure the head studs are fully seated in the jug.

I helicoil ex the cylinder head studs. And btw it's a 1995

But did you fix the studs properly? Are they secure and seated properly..Are any of the nuts stripped?..... lets see pictures of your work.

Does it have the original acorn style nuts?...if not then it should..I dont have a $550 torque wrench..I just have 550 years of experience...8^)

See, just as we thought...you ARE a grunmpy old guy. 

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now