Jump to content
Sign in to follow this  

1995 Kawasaki Ninja ZX6E Stalling Issue

Recommended Posts

Hey, first time using thumpertalk so hopefully I can get some helpicon1.png.

I've got a 1995 Kawasaki Ninja ZX6E that has been stalling on me.

I have cleaned the carbs thoroughly,cleaned the air filter, adjusted the fuelicon1.png/air screws, adjusted the idle, put a new fuel filter on, new fuel lines, cleaned the tank, and cleaned as best as I could the fuel pump.

When I got the bikeicon1.png, the carbs and fuel filter were very dirty. There were whole bugs in the carbs! I fixed the seals that were letting air blow by the filter. 
It ran ok. Not much bottom end and at 7k-8k rpm it hesatates to go fastericon1.png for 10 or so seconds and finally takes off. This is around 100 mph that it does this. Also when accelerating hard between 4k-6k rpm, if I pull the clutch in, the bike goes way down in rpms and stalls.
This happens only when I'm accelerating fasticon1.png and pull the clutch in. The bike does not sputter. Nice smooth power.

After cleaning the carbs and everything else the bike runs a lot stronger and sounds a lot cleaner.
Buuuuuut, the stalling is still there. It is a little better now. It can save itself sometimes without me having to releaseicon1.png the clutch or twist the throttle. 

Just need some suggestions on problem solving this. Let me know please! Thank you. 

Share this post


Link to post
Share on other sites

Update:

 

 

Stalled on me again yesterday randomly. Was not pulling clutch. Cruising at steady speed and bike started sputtering. Was able to ride it for another 2 miles till it gave up. Just took it all apart today and it started without the fuel pump and tank attached. Still sputtered but stayed running. Took spark plugs out and they are black but not oil covered.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...