Jump to content
Sign in to follow this  

Need a little help.

Recommended Posts

OK Guys,

 

I bought a 2006 DRZ-400SM with 22,000 last fall.  It had a bundle of problems, but I was confident I could figure it out. The first problem I tackled was the butchered wiring harness.  There was a direct short wired into it and the rear brake light switch was hot wired directly to the battery.  After that, it was running rich, but it started and ran.  I suspected that the re-jet of the carb was also botched.  This spring, before I could get everything together to rebuild the carb, it died in the drive as I pulled in one day and hasn't ran since.

 

I have now cleaned the carb repeatedly and properly rebuilt and re-jetted the carb.  It is still sick.  When I try to start it, it starts and runs for a few seconds and dies.  Over and over, it runs for 3-5 seconds then dies.  I checked that it is getting fuel from the tank and the float is set right, etc. etc.  I am stumped.  Can anyone give me a suggestion on where to look next?

 

Thanks in advance.  I have learned a lot just lurking and reading old posts.

Share this post


Link to post
Share on other sites

Welll, the hard part is figuring out if you have an electrical problem or a fuel problem. If it is fuel, it sounds like it is simply running out of gas. Verify the bowl vent is open.  Try a squirt gun with gas in the intake to keep it running  

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...