Jump to content
Sign in to follow this  

Yz125 problems (help)

Recommended Posts

Hi all,

I recently purchased a 1996 yz125 with low compression, I put a brand new piston and rings in it and put it back together... I started it for the first time after the rebuild and it had a loud chatter and wouldn't idle, yes I know the powervalve chatters but this is 10x louder. I took it all apart and cleaned the powervalve and made sure everything was in right, it was all good so I put it back together and tried it again. It still made the sound and doesn't idle. So I just gave up and took it for a ride, it stalled 5 times and bogged like hell. I'm not new to 2 strokes so don't tell me I'm riding it wrong and I have rebuild a few before too. Please all help is appreciated

Share this post


Link to post
Share on other sites

Hi all,

I recently purchased a 1996 yz125 with low compression, I put a brand new piston and rings in it and put it back together... I started it for the first time after the rebuild and it had a loud chatter and wouldn't idle, yes I know the powervalve chatters but this is 10x louder. I took it all apart and cleaned the powervalve and made sure everything was in right, it was all good so I put it back together and tried it again. It still made the sound and doesn't idle. So I just gave up and took it for a ride, it stalled 5 times and bogged like hell. I'm not new to 2 strokes so don't tell me I'm riding it wrong and I have rebuild a few before too. Please all help is appreciated

Share this post


Link to post
Share on other sites

Prob a lower end bearing post a video so we can hear it or some times a new piston will hit the dome, is it a dome top piston it could be hitting your head, piston in backwards? If its not a flat t opp p piston its prob the problem

Share this post


Link to post
Share on other sites

Prob a lower end bearing post a video so we can hear it or some times a new piston will hit the dome, is it a dome top piston it could be hitting your head, piston in backwards? If its not a flat t opp p piston its prob the problem

I'm almost definate my crank seals are bad, I don't know how to post a video

Share this post


Link to post
Share on other sites

Had a strange knocking sound on a CR125.  Ended up being a lose exhaust clamp and the exhaust not being lined up right.   My YZ 250 had a funny rattle the other day and it turned out to be the isolation mount on the exhaust pipe at the front of the bike. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...