Jump to content
Sign in to follow this  

Exhaust leak on 200xc-w

Recommended Posts

Just got an '07 200xc-w. Leaks right where the header goes into the head. Put new o rings, and springs on it. Still leaks. I dont even like riding it like this, you can feel the air shooting out and it spits oil/gas out on the pipe. Maybe the pipe is just old and worn off on the end? Or maybe the plate where the header goes into?

Share this post


Link to post
Share on other sites

I used a high temp RTV sealant when I replaced my o-ring. No smoke, no spooge, etc

  • Like 1

Share this post


Link to post
Share on other sites

After reading around i actually just put on some rtv super black (i think). Gonna let it sit overnight and see what it does tomorrow. Did u put it around the o rings or put the pipe on and then put it on?

Share this post


Link to post
Share on other sites

Just like zoom said, take it off clean it all up so the high temp RTV will stick and put your o rings on and put a decent coating around the o rings enough so that it will push just enough around to create a seal!

Share this post


Link to post
Share on other sites

it may be bent and is not square to the flange. Or it may not be put on correctly, as in the order of tightening the mounts and when the springs should be put on.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...