Jump to content
Sign in to follow this  

TE310 just cut out! wont start

Recommended Posts

Hi Guys,

I have recently bought a 2009 TE310, the last day I was driving along the road and the bike cut out? I noticed when I tryed to start it (with button not kick) there was no fuel pump sound only a clicking noise from one of the realys.......  when I got it home I checked it out and the wires going in to the realy looked doge so I done a job on it..... I then switched the realys around and the fuel pump worked...... so must have been a realy fualt right? anyway I was wondering do any of you guys know were I can buy these realys? any thoughts on good internet shops for husky parts?

cheers

 

also do these bike give alot of trouble as I am new to this type of bike would just be nice to know or rather a advanced warning!

 

 

 

 

 

20140731_194053.jpg

Share this post


Link to post
Share on other sites

Hi, I had similar problem couple weeks ago.  I went down hard one day and the positive power lead from battery to power / starter relay was shorting on frame.  It ended up causing the fuel pump relay to fail.

So fuel pump relay was done.  Plus battery ended up with a dead cell too.

 

Fuel pump, Fan, and Lights relays are the same.  They are a panasonic relay and are available from electronics sources.  I bought three from Mouser Electronics.  Goto Mouser dot com

 

mouser # 769-CA1A-12V-A-5

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...