Jump to content
Sign in to follow this  

What the F is wrong with my bike?help!

Recommended Posts

I have a Yamaha XT 600. When I start it, it wants to run(a little rough). While it warms up it gets rougher. Till finally its barely running and then its dead. Once it is warmed up to that level you can't even start it.

I have replaced the cdi box and the stator (both OEM parts). It has had a couple tune ups also.

I can't figure it out and so far I've put more in to it then I paid for it.... Can anyone save this classic bike from a gruesome death off the cliff near my house?

Share this post


Link to post
Share on other sites

Have you checked to see if its a fuel supply problem ?  Plugged up petcock ? sticking float/crap in carb ? clogged fuel cap vent ?

 

Also check the posts in the "Yamaha dualsport" forum and post up in there.

Edited by jetfuel
  • Like 1

Share this post


Link to post
Share on other sites

Thank you. But. I had a friend come over and he pulled the air cleaner and ran it hot and it cleared up like a bad cold.

Share this post


Link to post
Share on other sites

Are you sure the CDI was even good? the oem are going bad(even when not in use)from age. But it does sound like carb problems, running rich maybe, does it blow any black smoke when you give it throttle?

 

Don't throw it away they are good bikes(a bit tempermental with those SOB carbs though), I have 5 !

Share this post


Link to post
Share on other sites

jjktmrider_ I believe it was all carb issue. I put 60 miles on it after we got it to run. It is much stronger in the low end then before also. Pulls like a tractor! Thanks again for the input.

AM

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...