Jump to content
Sign in to follow this  

2003 yz250f !

Recommended Posts

2003 yz250f brand new bottom end, brand new top end, brand new 2010 yz250f carb with 2003 stock needle and jets, valves have been shimmed to specs. Now it will start and idle but when I hit the gas it bogs really bad and if I get it out of the bog it will rev great but then I have a hanging idle. I have gone leaner and rich on the pilot and turned the mixture screw in every position possible. Some times its hard to start I haven't replaced the stator but that wouldn't cause a hanging idle. Am I missing something here.

 

Share this post


Link to post
Share on other sites

Am I wrong thinking a 2010 carb isn't going to work right with '03 jetting regardless of what motor it's on?  Maybe 2010 jetting is a better place to start.

Share this post


Link to post
Share on other sites

The 03 came with a 100 leak jet.  That is most likely the bog problem.  Change the leak jet to 75 or so and give that a try.

As for hanging idle, I have it with my 05 bike, not with my 04 bike.  Only difference in the two is JD jet kit vs another brand jet kit.

I'd say get the JD jet kit which has a needle that is pure magic.

 

Also, the pilot jet will influence the hanging idle somewhat.  Make sure its clean or replace with a new one.  Should be a 40 or 42.

Share this post


Link to post
Share on other sites

I got rid of the bog it was the float height... Now it idles great and rev's great on the stand but when I start riding it has a hesitation all the way to about 1/2 throttle then it takes off and it seems to get worst the hotter it gets and if it cuts off it hard to start but super easy when cold... I know the needle would have something to do with the hesitation but I also think It could be the stator or something to do withe the ignition system maybe??? Can anyone tell me how to test the ignition system???

 

pilot 42

needle OBELP (stock)

needle clip 4th from top (stock)

main 178 (stock)

leak jet 70

(Brand new carb and jets)

Share this post


Link to post
Share on other sites

I fixed it I raised the needle 1 position and took a ride, it was horrible just as bad as before. Then I stopped cut it off and unplugged the TPS and bomb it runs great, very small hesitation but now that I know the cause I will order the JD jet kit I've already done the oring mod. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...