Jump to content
Sign in to follow this  

Drz400 fcr39 jetting.

Recommended Posts

Here my list of mods. Big bore 447cc. Hot cams stage 1. 3x3 mod. Aftermarket exhaust. And just bought the fcr39 From the tt store. So I followed there instructions emn needle 3rd clip, air screw 2 turns out. Removed air pilot. And have there standard jetting 160 main 45 pilot. I figured a good starting point. The bike will only start if I twist the throttle a couple of times and leave the choke on. Once I turn the choke off it dies. Idle is turned all the way up which doesn't help. Any help would be great thanks.

Share this post


Link to post
Share on other sites

Sounds like the pilot jet is plugged up.  If not that, put in a 100 pilot sir jet.

Share this post


Link to post
Share on other sites

There are 2 choices:  Too rich or too lean.  Since it needs a squirt from the AP and choke to run.  It certainly sounds lean when the choke is released.  With the idle turned all the way up you are mostly on the main circuit.

 

You say the pilot jet is not plugged up.  Did you look thru it and squirt carb cleaner thru it to verify? If not, I would do that.  If yes, then put the 100 pilot air jet in.  That should bring the idle mixture into some approach of normal.

 

Oh and verify the throttle plate is not in upside down.   The throttle should open from the center not the sides.

Share this post


Link to post
Share on other sites

What's the go with the 447cc kit?...which kit is that?

Did you physically check all jets were secure when before installation, namely the pilot jet..?

If your using a vacuum petcock is the vacuum nipple installed in the head and connected correctly...

Does starting make a difference if the petcock is turned to prime.?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...