Jump to content
Sign in to follow this  

Front brakes not working...

Recommended Posts

I bought a 2006 ktm 300xc which had been sitting for over 3 years. The front brake lever squeezed all the way to the grip without resistance. I installed a master cylinder rebuild kit and bled the system, but the lever still goes all the way and the brakes still don't work. Could it be the caliper? Has anyone experienced this before? Not sure what to do next

Share this post


Link to post
Share on other sites

You need to do some research on brake bleeding, it's not easy due to the tiny port size.

Lots of guys use a pressure bleeder on their brakes but I have had good luck with a Mityvac and a hammer.

Share this post


Link to post
Share on other sites

Can you manually retract the brake piston ?

The brakes are not stuck "on". The caliper will not squeeze. Maybe it's air in the line, maybe something else? I bled them through the bleeder screw down on the caliper by having a friend squeeze the lever while I open the bleeder, then close it. Did this many times, but either the air is not getting out completely, or I have another problem??

Share this post


Link to post
Share on other sites

If your caliper is not moving at all with then I suspect the caliper. Even if you had air in the line you would at least  have mushy breaks.. The inner pad isn't frozen on the slide pin is it ? Dried mud or twig jammed in there ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...