Jump to content
Sign in to follow this  

Help fitting E head pipe to S model RS3 Yosh Slip on a DRZ400S 05

Recommended Posts

I own a 05 Drz400 S.  Does anyone have any experience adapting a E head pipe onto a yosh RS3 slip-on? It wasn't as easy as fitting the E header onto my S slip. Any suggestion? I have already expanded the RS3 slip. Do I need to cut off some of the E head to fit the RS3? Thank you for any input as I couldn't find much.  Thanks

Share this post


Link to post
Share on other sites

I own a 05 Drz400 S.  Does anyone have any experience adapting a E head pipe onto a yosh RS3 slip-on? It wasn't as easy as fitting the E header onto my S slip. Any suggestion? I have already expanded the RS3 slip. Do I need to cut off some of the E head to fit the RS3? Thank you for any input as I couldn't find much.  Thanks

Take both pieces to a muffler shop and they'll figure out how to mate them.

  • Like 1

Share this post


Link to post
Share on other sites

 That's the easy way.  LOL

 I thought the RS3 was FOR E model DRZ's??? Assumed it fit the stock header since it's already oversized.   hmmmmm

Share this post


Link to post
Share on other sites

That's the easy way. LOL

I thought the RS3 was FOR E model DRZ's??? Assumed it fit the stock header since it's already oversized. hmmmmm

Lol I took the harder route. Dremel, rubber hammer heat gun and some lube gets the job done. Here is the link of the yosh slip I got on fleabay

http://www.ebay.com/itm/301268618247

Is that a rs3? Didn't say on the link and they guy only knew it was a sm yosh slip on. I had to have it expanded at I muffler shop to fit the e header but didn't get it expanded enough and the E header was too long. I post some videos and photos this weekend. Thanks for the replying

Share this post


Link to post
Share on other sites

Yes....That's an RS-3....

Throw up some pics of the mid pipe mounting with the pipe in situ (the area near the passenger peg ).

ImageUploadedByThumper Talk1408339765.167185.jpgImageUploadedByThumper Talk1408339787.666424.jpgImageUploadedByThumper Talk1408339811.718257.jpgImageUploadedByThumper Talk1408339832.534862.jpg

I'm not much of a photog as you can tell.

Rear passenger peg bolt feels like it wants strip the threads so I left as is..Feels solid. In addition, my E header is touching part of my radiator. Not sure if that's a bad thing? The slip on also feel so low in the rear like it wants to touch my rear wheel! Minor little exhaust little around the clamp area... going to quicksteel around it to seal better. What are your thoughts?

Edited by reydelacosta

Share this post


Link to post
Share on other sites

My Thoughts.???.......M8... :facepalm: ..The fit looks like a real abortion .... :facepalm:  :facepalm:  :facepalm:

 

the mid pipe mount bolt doesn't look like it's going in square, it's probably cross threaded, so that's why it would feel like it's going to strip...

 

The muffler mount should have both flanges to the right side of the sub frame, the pipe is too far left, that's why it would be hitting the tyre..

 the mid pipe area is not sitting snug against the bracket, this line is relaying to the back end of the muffler..

 

You need to have the header NOT TOUCHING the radiator, it doesn't need much clearance, it just needs to fudged away from the rad....if for some reason you can't move it , remove the header and give it a hit with a hammer to dent the pipe a little where it touches the rad...

Edited by Craig-o
  • Like 1

Share this post


Link to post
Share on other sites

ImageUploadedByThumper Talk1416591911.486215.jpg

Ordered some parts from yosh and it is good now. No exhaust leaks at the connection either. Just carb issues now. Think maybe a bad connection at the boots to the carb or something. It turns on with one pull on choke for a few seconds and sounds like it's not getting enough gas then makes a awful noise and cuts out..

Share this post


Link to post
Share on other sites

Hi, i have the RS3 exhaust on a 2007 DRZ400SM, for some reason, mine is rubbing on the rear suspension. is this normal? i have it mounted on the 3rd hole in the peg. and i also dont have the spacer on the exhaust clamp. ill link some pictures soon.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...